

    
      
          
            
  
Welcome to Read the Docs

This is an autogenerated index file.

Please create an index.rst or README.rst file with your own content
under the root (or /docs) directory in your repository.

If you want to use another markup, choose a different builder in your settings.
Check out our Getting Started Guide [https://docs.readthedocs.io/en/latest/getting_started.html] to become more
familiar with Read the Docs.
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ethernet-fmc-axi-eth

Example design for the [Quad Gigabit Ethernet FMC](http://ethernetfmc.com “Ethernet FMC”) using 4 AXI Ethernet blocks.

## Requirements

This project is designed for version 2019.2 of the Xilinx tools (Vivado/Vitis/PetaLinux).
If you are using an older version of the Xilinx tools, then refer to the
[release tags](https://github.com/fpgadeveloper/ethernet-fmc-axi-eth/releases “releases”)
to find the version of this repository that matches your version of the tools.

In order to test this design on hardware, you will need the following:


	Vivado 2019.2


	Vitis 2019.2


	PetaLinux SDK 2019.2


	[Ethernet FMC](http://ethernetfmc.com “Ethernet FMC”)


	One of the below listed evaluation boards


	[Xilinx Soft TEMAC license](http://ethernetfmc.com/getting-a-license-for-the-xilinx-tri-mode-ethernet-mac/ “Xilinx Soft TEMAC license”)




## Supported carrier boards


	Zynq-7000 [ZedBoard](http://zedboard.org “ZedBoard”)
* LPC connector


	Zynq-7000 [MicroZed FMC Carrier](http://zedboard.org/product/microzed-fmc-carrier “MicroZed FMC Carrier”) with [MicroZed 7Z020](http://microzed.org “MicroZed”)
* LPC connector


	Zynq-7000 [PicoZed FMC Carrier Card V2](http://zedboard.org/product/picozed-fmc-carrier-card-v2 “PicoZed FMC Carrier Card V2”) with [PicoZed 7015/20/30](http://picozed.org “PicoZed”)
* LPC connector


	Artix-7 [AC701 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-a7-ac701-g.html “AC701 Evaluation board”)
* HPC connector


	Kintex-7 [KC705 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-k7-kc705-g.html “KC705 Evaluation board”)
* LPC connector
* HPC connector


	Kintex UltraScale [KCU105 Evaluation board](http://www.xilinx.com/products/boards-and-kits/kcu105.html “KCU105 Evaluation board”)
* LPC connector
* HPC connector


	Virtex-7 [VC707 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-v7-vc707-g.html “VC707 Evaluation board”)
* HPC connector 1
* HPC connector 2


	Virtex-7 [VC709 Evaluation board](http://www.xilinx.com/products/boards-and-kits/dk-v7-vc709-g.html “VC709 Evaluation board”)
* HPC connector


	Zynq-7000 [ZC702 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-z7-zc702-g.html “ZC702 Evaluation board”)
* LPC connector 1
* LPC connector 2


	Zynq-7000 [ZC706 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-z7-zc706-g.html “ZC706 Evaluation board”) (LPC only)
* LPC connector


	Zynq UltraScale+ ZCU102 Evaluation board
* HPC0 connector
* HPC1 connector (design limited to 2 ports only)


	Zynq UltraScale+ [UltraZed EV Carrier Card] (http://zedboard.org/product/ultrazed-ev-carrier-card “UltraZed EV Carrier Card”)
* HPC connector


	Virtex Ultrascale+ [VCU118 Evaluation board] (https://www.xilinx.com/products/boards-and-kits/vcu118.html “VCU118 Evaluation board”)
* HPC1 connector




## 8-port Support (2 x Ethernet FMCs)

The only Evaluation boards that can support two Ethernet FMCs simultaneously are the
[KC705](http://www.xilinx.com/products/boards-and-kits/ek-k7-kc705-g.html “KC705 Evaluation board”),
[KCU105](http://www.xilinx.com/products/boards-and-kits/kcu105.html “KC705 Evaluation board”),
[ZC702](http://www.xilinx.com/products/boards-and-kits/ek-z7-zc702-g.html “ZC702 Evaluation board”)
and [VC707](http://www.xilinx.com/products/boards-and-kits/ek-v7-vc707-g.html “VC707 Evaluation board”).

This repository contains example designs for using 2 x Ethernet FMCs on the same carrier. They all use 8
Xilinx AXI Ethernet Subsystem IPs that are configured with DMAs, except for the ZC702 design, which is configured with FIFOs.
The reason for this is a lack of FPGA resources as using 8 MACs configured with DMAs requires more resources than is
contained in the Zynq device of that board.

These notes provide more details on 8-port support:


	The KC705 and VC707 each have two FMC connectors that support the Ethernet FMC (use kc705-lpc-hpc.xdc and vc707-hpc2-hpc1.xdc respectively).


	The KCU105 can support two Ethernet FMCs however the LPC only supports 3 ports so the dual design contains




only 7 ports total.
The critical block which does not pass timing requirements is the axi_mem_intercon.
* The ZC702 has two FMC connectors that can support the Ethernet FMC, however note that the Zynq device on this board has limited FPGA resources
for supporting 8 x Xilinx AXI Ethernet IPs (ie. the MACs). The device has enough resources when the 8 MACs are configured with FIFOs, however there are insufficient
resources to configure them with DMAs. Alternatively, you could use a MAC that requires less resources. (use zc702-lpc2-lpc1.xdc)
* The ZC706 has two FMC connectors, but only one (the LPC) can support the Ethernet FMC (see detail in board specific notes below).

## Description

This project demonstrates the use of the Opsero [Quad Gigabit Ethernet FMC](http://ethernetfmc.com “Ethernet FMC”).
The design contains 4 AXI Ethernet blocks configured with DMAs.

![Block diagram](http://ethernetfmc.com/wp-content/uploads/2014/10/qgige_all_axi_ethernet.png “Zynq Quad Gig Ethernet All AXI Ethernet”)

> Note: Zynq PS block is replaced by MicroBlaze processor for the Artix, Kintex and Virtex boards.

## Build instructions

To use the sources in this repository, please follow these steps:

### Windows users


	Download the repo as a zip file and extract the files to a directory
on your hard drive –OR– Git users: clone the repo to your hard drive


	Open Windows Explorer, browse to the repo files on your hard drive.


	In the Vivado directory, you will find multiple batch files (*.bat).
Double click on the batch file that is appropriate to your hardware,
for example, double-click build-zedboard.bat if you are using the ZedBoard.
This will generate a Vivado project for your hardware platform.


	Run Vivado and open the project that was just created.


	Click Generate bitstream.


	When the bitstream is successfully generated, select File->Export->Export Hardware.
In the window that opens, tick “Include bitstream” and “Local to project”.


	Return to Windows Explorer and browse to the Vitis directory in the repo.


	Double click the build-vitis.bat batch file. The batch file will run the
build-vitis.tcl script and build the Vitis workspace containing the hardware
design and the software application.


	Run Xilinx Vitis and select the workspace to be the Vitis directory of the repo.


	Connect and power up the hardware.


	Open a Putty terminal to view the UART output.


	In Vitis, select Xilinx Tools->Program FPGA.


	Right-click on the application and select Run As->Launch on Hardware (Single Application Debug)




### Linux users


	Download the repo as a zip file and extract the files to a directory
on your hard drive –OR– Git users: clone the repo to your hard drive


	Launch the Vivado GUI.


	Open the Tcl console from the Vivado welcome page. In the console, cd to the repo files
on your hard drive and into the Vivado subdirectory. For example: cd /media/projects/ethernet-fmc-axi-eth/Vivado.





	In the Vivado subdirectory, you will find multiple Tcl files. To list them, type exec ls {*}[glob *.tcl].
Determine the Tcl script for the example project that you would like to generate (for example: build-zedboard.tcl),
then source the script in the Tcl console: For example: source build-zedboard.tcl


	Vivado will run the script and generate the project. When it’s finished, click Generate bitstream.


	When the bitstream is successfully generated, select File->Export->Export Hardware.
In the window that opens, tick “Include bitstream” and “Local to project”.


	To build the Vitis workspace, open a Linux command terminal and cd to the Vitis directory in the repo.


	The Vitis directory contains the build-vitis.tcl script that will build the Vitis workspace containing the hardware design and
the software application. Run the build script by typing the following command:
<path-of-xilinx-vitis>/bin/xsct build-vitis.tcl. Note that you must replace <path-of-xilinx-vitis> with the
actual path to your Xilinx Vitis installation.


	Run Xilinx Vitis and select the workspace to be the Vitis subdirectory of the
repo.


	Connect and power up the hardware.


	Open a Putty terminal to view the UART output.


	In Vitis, select Xilinx Tools->Program FPGA.


	Right-click on the application and select Run As->Launch on Hardware (Single Application Debug)




## Stand-alone software application

The software application used to test these projects is the lwIP Echo Server example that is built into
Xilinx Vitis. The application relies on the lwIP library (also built into Xilinx Vitis) but with a few modifications.
The modified version of the lwIP library is contained in the EmbeddedSw directory, which is added as a
local software repository to the Vitis workspace. See the “README.md” file in the Vitis directory for more information.

### Single port limit for lwIP echo server

The echo server example design currently can only target one Ethernet port at a time.
Selection of the Ethernet port can be changed by modifying the defines contained in the
platform_config.h file in the application sources. Set PLATFORM_EMAC_BASEADDR
to one of the following values depending on the port you want to target:


	Ethernet FMC Port 0: XPAR_AXIETHERNET_0_BASEADDR


	Ethernet FMC Port 1: XPAR_AXIETHERNET_1_BASEADDR


	Ethernet FMC Port 2: XPAR_AXIETHERNET_2_BASEADDR


	Ethernet FMC Port 3: XPAR_AXIETHERNET_3_BASEADDR




## PetaLinux

This repo contains a script and configuration files for a PetaLinux project for each one of the hardware platforms. To build
the PetaLinux project, please refer to the “README.md” file in the PetaLinux subdirectory of this repo.

## Board specific notes

### AC701


	The AC701’s on-board Ethernet port is not connected in this design.


	This design includes a reset GPIO so that the MicroBlaze can reset itself from PetaLinux.




### KC705


	The KC705’s on-board Ethernet port is connected to AXI EthernetLite IP in these designs.


	This design includes a reset GPIO so that the MicroBlaze can reset itself from PetaLinux.




### VC707 & VC709


	These boards can only support the 1.8V version Ethernet FMC. The device on these boards have only HP (high-performance)




I/Os which do not support 2.5V levels.

### ZC706


	Zynq-7000 [ZC706 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-z7-zc706-g.html “ZC706 Evaluation board”) (HPC)
* HPC connector: Pins LA18_CC and LA17_CC of the HPC connector are routed to non-clock-capable pins so they cannot
properly receive the RGMII receive clocks for ports 2 and 3 of the Ethernet FMC. The constraints file zc706-hpc.xdc is
provided for reference, however it will not pass compilation with the Xilinx tools due to this problem.




### KCU105


	This board can only support the 1.8V version Ethernet FMC. The device on this board has only HP (high-performance)




I/Os which do not support 2.5V levels.
* KCU105 board design for the LPC connector is configured for only 3 ports as there is a strange placement error which occurs when trying
to build a design with 4 ports. The placement error has to do with IDELAYs and I have not reached a solution for this yet. There
is no such problem with the HPC for this board.

### ZCU102


	These designs support the ZCU102 Rev 1.0 and newer boards. Use a commit before 2016-02-13 for the older Rev-D board design.




Note that the FMC pinouts differ between Rev 1.0 and Rev D: https://www.xilinx.com/support/answers/68050.html
* This board can only support the 1.8V version Ethernet FMC. The device on this board has only HP (high-performance)
I/Os which do not support 2.5V levels.
* The HPC1 design only supports 2 ports due to the HPC1 pin assignment to the Zynq US+ (see constraints file for more details).

### PicoZed

#### Differences between designs

This repository contains a Vivado design for these PicoZed versions: 7Z020, 7Z015 and 7Z030.
The main differences between the designs are described below:


	7Z020: We use 4x AXI Ethernet IPs. The constraints file uses the 2.5V IO standards.


	7Z015: We use 4x AXI Ethernet IPs. The constraints file uses the 2.5V IO standards.


	7Z030: We use 4x AXI Ethernet IPs. The constraints file uses the 1.8V IO standards because this device has HP I/Os.




#### Installation of MicroZed, PicoZed and UltraZed board definition files

To use the projects for the MicroZed, PicoZed and UltraZed, you must first install the board definition files
for those boards into your Vivado and Vitis installation.

The following folders contain the board definition files and can be found in this project repository at this location:

https://github.com/Avnet/bdf


	microzed_7010


	microzed_7020


	picozed_7010_fmc2


	picozed_7015_fmc2


	picozed_7020_fmc2


	picozed_7030_fmc2


	ultrazed_7ev_cc




Copy those folders and their contents into the C:XilinxVivado2019.2databoardsboard_files folder (this may
be different on your machine, depending on your Vivado installation directory). You also need to make a copy into the
Vitis installation at this location: C:XilinxVitis2019.2databoardsboard_files.

## Microblaze design differences

The designs for AC701, KC705, VC707, VC709 & KCU105 all use the Microblaze soft processor. These designs
have some specific differences when compared to the Zynq based designs:


	MIG - the MIG is required to exploit the DDR3/4 memory of the eval boards.


	AXI Timer - the lwIP echo server application requires a timer (Microblaze does not have one inherently).


	AXI UART16550 - the lwIP echo server application requires a UART for console output.




## Troubleshooting

Check the following if the project fails to build or generate a bitstream:

### 1. Are you using the correct version of Vivado for this version of the repository?
Check the version specified in the Requirements section of this readme file. Note that this project is regularly maintained to the latest
version of Vivado and you may have to refer to an earlier commit of this repo if you are using an older version of Vivado.

### 2. Did you correctly follow the Build instructions in this readme file?
All the projects in the repo are built, synthesised and implemented to a bitstream before being committed, so if you follow the
instructions, there should not be any build issues.

### 3. Did you copy/clone the repo into a short directory structure?
Vivado doesn’t cope well with long directory structures, so copy/clone the repo into a short directory structure such as
`C:projects`. When working in long directory structures, you can get errors relating to missing files, particularly files
that are normally generated by Vivado (FIFOs, etc).

## For more information

If you need more information on whether the Ethernet FMC is compatible with your carrier, please contact me [here](http://ethernetfmc.com/contact/ “Ethernet FMC Contact form”).
Just provide me with the pinout of your carrier and I’ll be happy to check compatibility and generate a Vivado constraints file for you.

## Contribute

We encourage contribution to these projects. If you spot issues or you want to add designs for other platforms, please
make a pull request.

## About us

This project was developed by [Opsero Inc.](http://opsero.com “Opsero Inc.”),
a tight-knit team of FPGA experts delivering FPGA products and design services to start-ups and tech companies.
Follow our blog, [FPGA Developer](http://www.fpgadeveloper.com “FPGA Developer”), for news, tutorials and
updates on the awesome projects we work on.





            

          

      

      

    

  

    
      
          
            
  
Modified BSP files

### lwIP modifications

This project uses a modified version of the lwIP library in order for it to work with the Marvel 88E1510/88E1518
PHYs on the Ethernet FMC.

A function is added to xaxiemacif_physpeed.c for the initialization of the Marvell 88E1510 Ethernet PHY

### AXI Ethernet driver modifications (applies only to versions 5.6, 5.7, 5.8 and 5.9)

There is a bug in the TCL script for the AXI Ethernet driver since version 5.6 (released with Xilinx SDK 2017.3).

For designs using the AXI FIFO (instead of AXI DMA), the below script fails at line 234 because variable
target_periph_name is not defined. This repo contains a fix for the bug.

Location of the original TCL script for Vitis 2019.2:
XilinxVitis2019.2dataembeddedswXilinxProcessorIPLibdriversaxiethernet_v5_9dataaxiethernet.tcl





            

          

      

      

    

  

    
      
          
            
  
PetaLinux Project source files

### How to build the PetaLinux projects

#### Requirements


	Windows or Linux PC with Vivado installed


	Linux PC or virtual machine with PetaLinux installed




#### Instructions

In order to make use of these source files, you must:


	First generate the Vivado project hardware design(s) (the bitstream) and export the design(s) to SDK.


	Launch PetaLinux by sourcing the settings.sh bash script, eg: source <path-to-installed-petalinux>/settings.sh


	Build the PetaLinux project(s) by executing the build-petalinux script in Linux.




The script will generate a separate PetaLinux project for all of the generated and exported Vivado projects that
it finds in the Vivado directory of this repo.

### UNIX line endings

The scripts and files in the PetaLinux directory of this repository must have UNIX line endings when they are
executed or used under Linux. The best way to ensure UNIX line endings, is to clone the repo directly onto your
Linux machine. If instead you have copied the repo from a Windows machine, the files will have DOS line endings and
you must use the dos2unix tool to convert the line endings for UNIX.


	Copy the cloned repository from your Windows machine to your Linux machine.


	Use the cd command to navigate to the copied repository on your Linux machine.




3. Type find . -type f -exec dos2unix –keepdate {} + to convert all of the files
to the Unix format.

### How the script works

The PetaLinux directory contains a build-petalinux shell script which can be run in Linux to automatically
generate a PetaLinux project for each of the generated/exported Vivado projects in the Vivado directory.

When executed, the build script searches the Vivado directory for all projects containing a .xsa exported
hardware design file. Then for every exported project, the script does the following:


	Verifies that the .bit file exists.




2. Determines the CPU type: Zynq or ZynqMP. It currently does this
by looking at the first 3 letters of the project name.
3. Creates a PetaLinux project, referencing the exported hardware design (.xsa).
4. Copies the relevant configuration files from the src directory into the created
PetaLinux project.
5. Builds the PetaLinux project.
6. Generates a BOOT.bin and image.ub file for the Zynq and ZynqMP projects.

### Launch PetaLinux on hardware

#### Via JTAG

To launch the PetaLinux project on hardware via JTAG, connect and power up your hardware and then
use the following commands in a Linux command terminal:

1. Change current directory to the PetaLinux project directory:
cd <petalinux-project-dir>
2. Download bitstream to the FPGA:
petalinux-boot –jtag –fpga
Note that you don’t have to specify the bitstream because this command will use the one that it finds
in the ./images/linux directory.
3. Download the PetaLinux kernel to the FPGA:
petalinux-boot –jtag –kernel

#### Via SD card (Zynq)

To launch the PetaLinux project on hardware via SD card, copy the following files to the root of the
SD card:


	/<petalinux-project>/images/linux/BOOT.bin


	/<petalinux-project>/images/linux/image.ub




Then connect and power your hardware.

### Configuration files

The configuration files contained in the src directory include:


	Device tree


	Rootfs configuration (to include ethtool)


	Interface initializations (sets eth0-3 interfaces to DHCP)


	Kernel configuration


	AXI Ethernet driver patch




#### AXI Ethernet driver patch

The AXI Ethernet driver requires a patch for the correct configuration of the RGMII interface’s
RX and TX clock skews.

https://github.com/Xilinx/linux-xlnx/blob/master/drivers/net/ethernet/xilinx/xilinx_axienet_main.c


	```             } else if (lp->phy_type == XAE_PHY_TYPE_RGMII_2_0) {
	
	phydev = of_phy_connect(lp->ndev, lp->phy_node,
	axienet_adjust_link, 0,
PHY_INTERFACE_MODE_RGMII_ID);









```

The section of the code shown above specifies PHY_INTERFACE_MODE_RGMII_ID as the RGMII interface
mode (aka “rgmii-id”). That interface mode enables both the RX and TX clock delays in the PHY but in
fact we need to enable only the RX delay
(see http://ethernetfmc.com/rgmii-interface-timing-considerations/ for more information).

Our device tree specifies the correct RGMII configuration with the phy-mode setting (“rgmii-rxid”),
and we have access to this setting via the lp->phy_interface variable. So to correct the issue, we
replace the above code with the following:


	```             } else if (lp->phy_type == XAE_PHY_TYPE_RGMII_2_0) {
	
	phydev = of_phy_connect(lp->ndev, lp->phy_node,
	axienet_adjust_link, 0,
lp->phy_interface);









```

The included patch handles this modification - you do not need to manually modify any code.

### Port configurations

All designs will try to automatically configure the eth0 device on boot, so it can be
useful to connect the eth0 device to a DHCP router before the hardware is powered-up.
Note that on Zynq and ZynqMP designs, the eth0 device is connected to the development board’s
Ethernet port and not the Ethernet FMC.

#### AC701, KC705


	eth0: Ethernet port of the dev board


	eth1: Ethernet FMC Port 0


	eth2: Ethernet FMC Port 1


	eth3: Ethernet FMC Port 2


	eth4: Ethernet FMC Port 3




#### KCU105 HPC, VC707, VC709


	eth0: Ethernet FMC Port 0


	eth1: Ethernet FMC Port 1


	eth2: Ethernet FMC Port 2


	eth3: Ethernet FMC Port 3




#### KCU105 LPC


	eth0: Ethernet FMC Port 0


	eth1: Ethernet FMC Port 1


	eth2: Ethernet FMC Port 3




Ethernet FMC Port 2 is unusable in this design.

#### MicroZed, PicoZed, ZC702, ZC706, ZedBoard, ZCU102


	eth0: GEM0 to Ethernet port of the dev board


	eth1: Ethernet FMC Port 0


	eth2: Ethernet FMC Port 1


	eth3: Ethernet FMC Port 2


	eth4: Ethernet FMC Port 3




#### KCU105 Dual design


	eth0: HPC Ethernet FMC Port 0 (AXI Ethernet)


	eth1: HPC Ethernet FMC Port 1 (AXI Ethernet)


	eth2: HPC Ethernet FMC Port 2 (AXI Ethernet)


	eth3: HPC Ethernet FMC Port 3 (AXI Ethernet)


	eth4: LPC Ethernet FMC Port 0 (AXI Ethernet)


	eth5: LPC Ethernet FMC Port 1 (AXI Ethernet)


	eth6: LPC Ethernet FMC Port 3 (AXI Ethernet)




Ethernet FMC Port 2 on the LPC is unusable in this design.

#### VC707 Dual design


	eth0: HPC2 Ethernet FMC Port 0 (AXI Ethernet)


	eth1: HPC2 Ethernet FMC Port 1 (AXI Ethernet)


	eth2: HPC2 Ethernet FMC Port 2 (AXI Ethernet)


	eth3: HPC2 Ethernet FMC Port 3 (AXI Ethernet)


	eth4: HPC1 Ethernet FMC Port 0 (AXI Ethernet)


	eth5: HPC1 Ethernet FMC Port 1 (AXI Ethernet)


	eth6: HPC1 Ethernet FMC Port 2 (AXI Ethernet)


	eth7: HPC1 Ethernet FMC Port 3 (AXI Ethernet)




#### ZC702 Dual design

Note that the ZC702 dual design will not produce a working PetaLinux project because it’s Ethernet
MACs are connected to FIFOs and not AXI DMAs. We are working on a solution to this.





            

          

      

      

    

  

    
      
          
            
  
Vitis Project files

### Important patch for Vitis 2019.2

To use the build script in this directory, you must first apply the following patch
to your Vitis installation:

https://www.xilinx.com/support/answers/73252.html

### How to build the Vitis workspace

In order to make use of these source files, you must first generate
the Vivado project hardware design (the bitstream) and export the hardware.
Check the Vivado folder for instructions on doing this from Vivado.

Once the bitstream is generated and exported, then you can build the
Vitis workspace using the provided build-vitis.tcl script.

### Scripted build

The Vitis directory contains a build-vitis.tcl script which can be run to automatically
generate the Vitis workspace. Windows users can run the build-vitis.bat file which
launches the Tcl script. Linux users must use the following commands to run the build
script:
`
cd <path-to-repo>/Vitis
/<path-to-xilinx-tools>/Vitis/2019.2/bin/xsct build-vitis.tcl
`

The build script does three things:

1. Prepares a local Vitis repository containing a modified version of lwIP library,
required by the echo server example application.
2. Adds the ../EmbeddedSw directory as a local Vitis repository.
3. Generates a lwIP Echo Server example application for each exported Vivado design
that is found in the ../Vivado directory. Most users will only have one exported
Vivado design.

### Run the application


	Open Xilinx Vitis.




2. Power up your hardware platform and ensure that the JTAG is
connected properly.
3. In the Vitis Explorer panel, double-click on the System project that you want to run -
this will reveal the applications contained in the project. The System project will have
the postfix “_system”.
4. Now click on the application that you want to run. It should have the postfix “_echo_server”.
5. Select the option “Run Configurations” from the drop-down menu contained under the Run
button on the toolbar (play symbol).
6. Double-click on “Single Application Debug” to create a run configuration for this
application. Then click “Run”.

The run configuration will first program the FPGA with the bitstream, then load and run the
application. You can view the UART output of the application in a console window.

### UART settings

To receive the UART output of this standalone application, you will need to connect the
USB-UART of the development board to your PC and run a console program such as
[Putty](https://www.putty.org “Putty”). The follow UART settings must be used:


	Microblaze designs: 9600 baud


	Zynq and ZynqMP designs: 115200 baud




### How to change the Ethernet port targetted by the application

The echo server example design currently can only target one Ethernet port at a time.
Selection of the Ethernet port can be changed by modifying the defines contained in the
platform_config.h file in the application sources. Set PLATFORM_EMAC_BASEADDR
to one of the following values:


	Ethernet FMC Port 0: XPAR_AXIETHERNET_0_BASEADDR


	Ethernet FMC Port 1: XPAR_AXIETHERNET_1_BASEADDR


	Ethernet FMC Port 2: XPAR_AXIETHERNET_2_BASEADDR


	Ethernet FMC Port 3: XPAR_AXIETHERNET_3_BASEADDR








            

          

      

      

    

  

    
      
          
            
  
Vivado Constraint files

### Supported FPGA boards and connectors

The Ethernet FMC can be used on both low-pin-count (LPC) and high-pin-count (HPC) FMC connectors. Some of the
supported FPGA boards have multiple FMC connectors, so be sure to use the constraint file that is
appropriate for the connector you want to use.


	Zynq-7000 [ZedBoard](http://zedboard.org “ZedBoard”)
* LPC connector (use zedboard.xdc)


	Zynq-7000 [PicoZed FMC Carrier Card V2](http://zedboard.org/product/picozed-fmc-carrier-card-v2 “PicoZed FMC Carrier Card V2”) with [PicoZed 7010/15/20/30](http://picozed.org “PicoZed”)
* LPC connector (use pzfmc-7z0xx.xdc)


	Artix-7 [AC701 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-a7-ac701-g.html “AC701 Evaluation board”)
* HPC connector (use ac701.xdc)


	Kintex-7 [KC705 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-k7-kc705-g.html “KC705 Evaluation board”)
* LPC connector (use kc705-lpc.xdc)
* HPC connector (use kc705-hpc.xdc)


	Kintex UltraScale [KCU105 Evaluation board](http://www.xilinx.com/products/boards-and-kits/kcu105.html “KCU105 Evaluation board”)
* LPC connector (use kcu105-lpc.xdc)
* HPC connector (use kcu105-hpc.xdc)


	Virtex-7 [VC707 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-v7-vc707-g.html “VC707 Evaluation board”)
* HPC connector 1 (use vc707-hpc1.xdc)
* HPC connector 2 (use vc707-hpc2.xdc)


	Virtex-7 [VC709 Evaluation board](http://www.xilinx.com/products/boards-and-kits/dk-v7-vc709-g.html “VC709 Evaluation board”)
* HPC connector (use vc709.xdc)


	Zynq-7000 [ZC702 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-z7-zc702-g.html “ZC702 Evaluation board”)
* LPC connector 1 (use zc702-lpc1.xdc)
* LPC connector 2 (use zc702-lpc2.xdc)


	Zynq-7000 [ZC706 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-z7-zc706-g.html “ZC706 Evaluation board”) (LPC only)
* LPC connector (use zc706-lpc.xdc)


	Zynq UltraScale+ ZCU102 Evaluation board
* HPC0 connector (use zcu102-hpc0.xdc)




### For more information

If you need more information on whether the Ethernet FMC is compatible with your carrier, please contact me [here](http://ethernetfmc.com/contact/ “Ethernet FMC Contact form”).
Just provide me with the pinout of your carrier and I’ll be happy to check compatibility and generate a Vivado constraints file for you.

Jeff Johnson
[FPGA Developer](http://www.fpgadeveloper.com “FPGA Developer”)
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